Outage and maintenance events typically affect only a small portion of the subscribers in a service area and do not necessarily indicate a city‑wide or network‑wide impact
Outage - Bountiful (TID#24001)
Resolved
Major outage
Started about 1 month agoLasted about 17 hours
Updates
Resolved
Resolved
Bountiful Fiber has resolved the outage in Bountiful. Services for affected customers have been restored.
Investigating
Investigating
Bountiful Fiber is investigating an outage in Bountiful. Affected customers may be without service.