UTOPIA Fiber Network Dev/Testing - Outage - Bozeman – Incident details
This is a test page and contains only test data
Report an issue
Get updates
Email
SMS
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Murray experiencing major outage
This is a test page and contains only test data
Outage - Bozeman
Resolved
Major outage
Started 16 days ago
Lasted 1 day
Updates
Resolved
January 19, 2026 at 7:56 PM
Resolved
January 19, 2026 at 7:56 PM
Yellowstone Fiber has resolved the outage. Services for affected customers have been restored.
Investigating
January 18, 2026 at 7:52 PM
Investigating
January 18, 2026 at 7:52 PM
Yellowstone Fiber is investigating an outage in Bozeman.