UTOPIA Fiber Network Dev/Testing - #21933 Outage – Incident details
This is a test page and contains only test data
Report an issue
Get updates
Email
SMS
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Murray experiencing major outage
This is a test page and contains only test data
#21933 Outage
Resolved
Major outage
Started 4 months ago
Lasted 3 minutes
Affected
Utah County
Major outage from 11:05 PM to 11:08 PM
Orem
Major outage from 11:05 PM to 11:08 PM
Updates
Resolved
October 17, 2025 at 11:08 PM
Resolved
October 17, 2025 at 11:08 PM
UTOPIA has resolved the outage. Services for affected customers have been restored.
Investigating
October 17, 2025 at 11:05 PM
Investigating
October 17, 2025 at 11:05 PM
UTOPIA is investigating an outage in Orem (OR006 and OR009). Affected customers may be without service.