UTOPIA Fiber Network Dev/Testing - #21935 Outage – Incident details
This is a test page and contains only test data
Report an issue
Get updates
Email
SMS
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Murray experiencing major outage
This is a test page and contains only test data
#21935 Outage
Resolved
Partial outage
Started 3 months ago
Lasted 16 minutes
Affected
Utah County
Partial outage from 9:25 PM to 9:40 PM
Payson
Partial outage from 9:25 PM to 9:40 PM
Updates
Update
November 12, 2025 at 9:40 PM
Update
November 12, 2025 at 9:40 PM
UTOPIA has resolved the outage. Services for affected customers have been restored.
Resolved
November 12, 2025 at 9:40 PM
Resolved
November 12, 2025 at 9:40 PM
UTOPIA has resolved the outage. Services for affected customers have been restored.
Investigating
November 12, 2025 at 9:25 PM
Investigating
November 12, 2025 at 9:25 PM
UTOPIA is investigating an outage in Payson and Goshen (PA004 and GON001). Affected customers may be without service.