UTOPIA Fiber Network Dev/Testing - #21934 Outage – Incident details
This is a test page and contains only test data
Report an issue
Get updates
Email
SMS
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Murray experiencing major outage
This is a test page and contains only test data
#21934 Outage
Resolved
Partial outage
Started 4 months ago
Lasted about 12 hours
Affected
Santa Clara
Partial outage from 6:00 AM to 6:08 PM
Updates
Resolved
October 22, 2025 at 6:08 PM
Resolved
October 22, 2025 at 6:08 PM
UTOPIA has resolved the outage. Services for affected customers have been restored.
Investigating
October 22, 2025 at 6:00 AM
Investigating
October 22, 2025 at 6:00 AM
UTOPIA is investigating an outage in Santa Clara (SC001). Affected customers may be without service.